This page is intentionally blank.
Document Approval

<table>
<thead>
<tr>
<th>Document Approved By</th>
<th>Date Approved</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name:</td>
<td>00/00/0000</td>
</tr>
</tbody>
</table>
## Revision History

<table>
<thead>
<tr>
<th>VERSION</th>
<th>DATE</th>
<th>PRIMARY AUTHOR(S)</th>
<th>REVISION/CHANGE</th>
<th>PAGES AFFECTED</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>31 JAN 2019</td>
<td>DISA RME</td>
<td>Original Draft</td>
<td>All</td>
</tr>
<tr>
<td>1.1</td>
<td>30 APR 2019</td>
<td>DISA RME</td>
<td>Added new content</td>
<td>Various</td>
</tr>
<tr>
<td>1.2</td>
<td>7 JUL 2019</td>
<td>DISA RME</td>
<td>Added new content</td>
<td>7 and 8</td>
</tr>
<tr>
<td>1.3</td>
<td>10 OCT 2019</td>
<td>DISA RME</td>
<td>Added new content</td>
<td>10, 16, and 17</td>
</tr>
<tr>
<td>1.4</td>
<td>15 JAN 2020</td>
<td>DISA RME</td>
<td>Added new content</td>
<td>11, 19, and 20</td>
</tr>
<tr>
<td>1.5</td>
<td>30 APR 2020</td>
<td>DISA RME</td>
<td>Added new content</td>
<td>9 and 24</td>
</tr>
</tbody>
</table>
Table of Contents

1 Introduction .......................................................................................................................... 6
   1.1 Purpose ............................................................................................................................... 6
   1.2 About the SRG/STIG Applicability Guide ................................................................. 6

2 Unpacking and Launching the Application ................................................................. 7
   2.1 Windows ............................................................................................................................... 7
   2.2 Mac OS ............................................................................................................................... 7
   2.3 Linux .................................................................................................................................. 7

3 Menu Bar .............................................................................................................................. 9
   3.1 File Menu ......................................................................................................................... 9
   3.2 View Menu ........................................................................................................................ 9
   3.3 Help Menu ........................................................................................................................ 9

4 Right Click Menu ........................................................................................................... 10
   4.1 Menu .................................................................................................................................. 10

5 Asset Tree .......................................................................................................................... 11
   5.1 Overview ............................................................................................................................ 11
   5.2 Adding Assets (Standard Mode) ..................................................................................... 12
   5.3 Adding Assets (Guide Mode) .......................................................................................... 13
   5.4 Adding Parent Assets ....................................................................................................... 16
   5.5 Adding Parent Assets (Guide Mode) .............................................................................. 18
   5.6 Editing Assets .................................................................................................................. 20
   5.7 Removing Assets .............................................................................................................. 22

6 Save, Open, and Merge ..................................................................................................... 23
   6.1 Overview ........................................................................................................................... 23
   6.2 Save Collection ............................................................................................................... 23
   6.3 Open Collection .............................................................................................................. 24
   6.4 Merge Collection ............................................................................................................ 25

7 Drag and Drop .................................................................................................................. 27
   7.1 Overview ........................................................................................................................... 27
   7.2 Drag and Drop Assets .................................................................................................... 27
   7.3 Drag and Drop Files ....................................................................................................... 27

8 Exports ............................................................................................................................... 29
   8.1 Overview ........................................................................................................................... 29
   8.2 Preview .............................................................................................................................. 29
   8.3 Exporting ......................................................................................................................... 30
9 Example..........................................................................................................................32
  9.1 Scenario .......................................................................................................................32
1 Introduction

1.1 Purpose

The purpose of the document is to familiarize users with the SRG/STIG Applicability Guide and its functions.

1.2 About the SRG/STIG Applicability Guide

The SRG/STIG Applicability Guide allows users to build a collection of assets pertaining to an environment, such as an information system. Using the collection built up by the user, the tool will determine the SRGs, STIGs, and other policy documents required by the user. The tool allows users to preview and export the policy documents as well as import and export the collection.

Application Functions:

- Two modes of asset addition for different levels of familiarity
- Drag and drop of assets in the asset tree
- Drag and drop asset collection files into the asset tree
- Import and export asset collections
- Export policy documents
- Preview policy documents
2 Unpacking andLaunching the Application

When downloading the SRG/STIG Applicability Guide, it will be in the form of a .zip file. This file will need to be unpacked before it can be used. These steps will only need to be performed initially. Follow the steps provided below according to the operating system you wish you use.

2.1 Windows

1. Open the .zip file provided and click “Extract all” on the top.

2. Double click the file titled “STIGApplicabilityGuide”.

2.2 Mac OS

1. Double click the downloaded .zip file. The files will be automatically extracted and it will create a new folder with the same name.

2. Open the newly created folder and double click the file titled “STIGApplicabilityGuide”.

2.3 Linux

1. Open the .zip file provided and click “Extract” on the top left.
2. Create a new folder and give it a name.

![Create Folder]

3. Open the newly created folder and on the top left, navigate to Files -> Preferences

![File Preferences]

4. Then, click on the “Behavior” tab and under “Executable Text Files”, select “Run them”, and close the window.

![Preferences]

5. Double click the file titled “STIGApplicabilityGuide” to open it.
3 Menu Bar

3.1 File Menu

The File Menu allows you to open, save, export, and create new asset collections.

3.2 View Menu

The View menu allows users to preview the current list of policy documents that apply to their asset posture. As more items are added to the tree, more items will show in the Document List.

3.3 Help Menu

The Help Menu contains information about the application, including the version number, release notes, a list of the applications dependencies and their licenses, and the ability to check for the latest version of the application.
4 Right Click Menu

4.1 Menu

Right clicking on an asset will provide a menu to the user. This menu has shortcuts to add an asset, edit the asset, remove the asset, and to enter Guide Mode. The right click menu also includes two features that are not available elsewhere; Add Parent and Add Parent using Guide Mode. Please note that these two features are only available if the selected asset and it’s current parent have matching assets.
5 Asset Tree

5.1 Overview

The portion of the application under the file menu to the left is the Asset Tree. Here you will be able to see your current collection as well as add, edit, or remove assets. The pane to the right side is the where users are prompted, and details of the application are selected.

1. To begin adding assets, navigate to the menu bar and select File → New Collection. An item will be added to the asset tree on the left. The first Item represents the asset collection. Name it accordingly or leave it blank to keep the name asset collection.
5.2 Adding Assets (Standard Mode)

1. Click the “+” button to add your first Asset.

2. After clicking the “+” button a selection pane will appear to the right. Here you can select the asset type (top right) that applies this asset. You will be able to see descriptions for each asset type as well as select the most fitting label* or labels (bottom left of the right pane) that apply to your asset type. Pressing submit will create an item on the asset tree representing that item.
3. Pressing “Submit” will create an item on the asset tree representing that item.

![Image of asset tree and label creation]

Notes:
- Selecting multiple labels (with checkboxes) will create multiple assets with the different labels selected.
- *Asset Label: a descriptive tag that applies to an asset

5.3 Adding Assets (Guide Mode)

1. Click the purple steering wheel next to the “+” button to begin Guide Mode

![Image of guide mode entry]

![Image of guide mode selection]
2. After clicking the Guide Mode button, a pane will appear to the right prompting you to add an asset.

3. Selecting “No” will take you to the next asset in the list. Selecting “Yes” will take you to the label pane where you will select a label (if available) and/or name the asset type.
4. After adding and submitting an asset you will descend into its children, so the next prompt will be the first child of the asset you just added. Once you have decided on whether to add each child you will be returned to the top level where you will continue to add other assets. This continues until you have gone through every asset type available.
Notes:

- Selecting multiple labels (with checkboxes) will create multiple tree items with the different labels selected.
- To leave Guide Mode click “End Guide”.

5.4 Adding Parent Assets

If you have an asset created and would like to go in reverse order and add a parent to it, you can do so using the “Add Parent” feature. Please note that the “Add Parent” feature will only be available if the selected asset and its current parent have matching assets.

1. Right click the asset you would like to add a parent to and select “Add Parent”.
2. On the right, you will see the list of assets available based off of the asset you selected and it’s current parent.

3. Select the asset you wish to add and click Submit. The new parent will now be added to your asset.
5.5 Adding Parent Assets (Guide Mode)

If you have an asset created and would like to go in reverse order and add a parent to it using the guide mode, you can do so using the “Add Parent” option when selecting Guide Mode. Please note that the “Add Parent” feature will only be available if the selected asset and its current parent have matching assets. It is also only available through the right-click menu.

1. Right click the asset you would like to add a parent to and select “Add Parent”.

2. On the right, Guide Mode will walk you through available asset labels based off of the asset you selected and its current parent.
3. Select “Yes” on the label you wish to add and click Submit. The new parent will now be added to your asset.

4. From here, if you could like to add a parent to the parent you just created, continue walking through the Guide Mode. Otherwise, click on “End Guide”.

![Asset Collection Tree](image-url)
5.6 Editing Assets

After Creating an asset, you can edit the asset using the green pencil button on the tree item for that asset.

1. Click the green pencil icon to begin editing an asset. A pane will appear on the right side with the current information of the asset.

2. Here you can change the name of the asset, and the label (if available). After making the required changes and pressing submit your changes will be reflected on the tree to the left.
5.7 Removing Assets

To remove an asset, click the “x” button on the tree item for that asset.

1. After clicking the “x” button a prompt will pop up asking if you to continue deletion. Clicking “OK” or pressing “ENTER” will delete the Asset and clicking “Cancel”, pressing “ESC”, or clicking the “X” on the top right will cancel deletion.
6 Save, Open, and Merge

6.1 Overview

When an asset posture has been built the application allows users to save the Collection as an XML document and later import it again. These options can be found under the file menu.

6.2 Save Collection

1. To save a collection: in the menu bar select File → Save Collection As… (clicking File → Save would also work).

2. A window will pop up allowing you to choose a save location as well as a file name. Pressing Save will save the collection.
6.3 Open Collection

1. To open an Asset Collection: in the menu bar select File → Open Collection…

2. Navigate to the location of your saved Asset Collection document, select it, and click open.

3. Your asset collection will be opened but collapsed

Note: If an imported asset has been sunset or deprecated, an indicator will be displayed next to the asset to notify the user. A yellow indicator signifies that it is sunset. A black indicator signifies that it is deprecated.
6.4 Merge Collection

Merging an asset collection allows you to import assets from an asset collection file into the currently open collection. When the merge operation is successful the assets of the merged collection will be appended to the end of the current collection. If there are currently no assets in the asset tree, all elements of the merged collection (including the top level asset) will be added to the asset tree without setting the save file.

1. To merge an Asset Collection: in the menu bar select File → Merge Collection…

2. Navigate to the location of your saved Asset Collection document, select it, and click open.

3. Merging Collections (With tree empty)
4. Merging Collections (With tree not empty)

5. Merging Collections (With save file loaded)
7  Drag and Drop

7.1  Overview

The SRG/STIG Applicability Guide is drag and drop enabled meaning that you can drag and drop a compatible asset into another asset. In addition, you may drag and drop a saved asset collection file to load it.

7.2  Drag and Drop Assets

1. To drag and drop an asset left click and hold with you mouse, then drag it to the intended asset. When the dragged asset encounters a compatible asset, the compatible asset will turn green otherwise it will be red.

![Compatible Item Dragged](image1)

![Incompatible Item Dragged](image2)

7.3  Drag and Drop Files

1. To open a file via drag and drop: drag the file over to the area of the asset tree and drop it. Valid files will either be opened (if tree is empty) or merged otherwise.

![Invalid File Dragged](image3)
File Warning (valid file type, invalid contents)
8 Exports

8.1 Overview

After building an asset collection, users can then export the requirements/policy documents using options in the File menu. Exports come in two file types, HTML, and Text, and in two varieties, normal/flat and asset-based list. The flat list only contains the policy documents and their information whereas the asset-based list also contains the asset that it applies to and the path to get to that asset.

8.2 Preview

1. To see a preview of your current collection: in the menu select View → Document List… A window will pop up with a list of the Requirements/Policy Documents that apply to the current asset posture.
8.3 Exporting

1. To export as text: in the menu select File → Export Assets (or Requirements Document) → Export … As Text (or HTML).

2. In the window that pops up you can save choose the location and name of the export file. Clicking save will save the file.

3. Examples:

Asset Based HTML


[Enclave or Network]: DoD Internet-NIPRNet DMZ - ALPHA

Document Title: NIPRNet DoD DMZ Policy STIG
Document Benchmark ID: NIPRNet_DoD_DMZ
URL: https://iase.disa.mil/stig/net_perimeter/enclave-dmz/Pages/index.aspx


[Cloud Service]: Cloud Service - AWS Endpoint

Document Title: Cloud Computing Security Requirements Guide
Document Benchmark ID: Cloud_SRG
URL: https://iase.disa.mil/cloud_security/Pages/index.aspx


[Application]: BIND 9.x Server - Bind Server

Document Benchmark ID: BIND_9x_STIG
URL: https://iase.disa.mil/stig/net_perimeter/network-other/Pages/index.aspx
### Flat HTML

**Document Title:** BIND 9.x Security Technical Implementation Guide  
**Document Benchmark ID:** BIND_9-x_STIG  
**URL:** https://iase.disa.mil/stigs/net_perimeter/network-other/Pages/index.aspx

**Document Title:** Cloud Computing Security Requirements Guide  
**Document Benchmark ID:** Cloud_SRG  
**URL:** https://iase.disa.mil/cloud_security/Pages/index.aspx

**Document Title:** NIPRNet DoD DMZ Policy STIG  
**Document Benchmark ID:** NIPRNet_DoD_DMZ  
**URL:** https://iase.disa.mil/stigs/net_perimeter/enclave-dmzs/Pages/index.aspx

### Flat Text

**Document Title:** BIND 9.x Security Technical Implementation Guide  
**Document Benchmark ID:** BIND_9-x_STIG  
**URL:** https://iase.disa.mil/stigs/net_perimeter/network-other/Pages/index.aspx

**Document Title:** Cloud Computing Security Requirements Guide  
**Document Benchmark ID:** Cloud_SRG  
**URL:** https://iase.disa.mil/cloud_security/Pages/index.aspx

**Document Title:** NIPRNet DoD DMZ Policy STIG  
**Document Benchmark ID:** NIPRNet_DoD_DMZ  
**URL:** https://iase.disa.mil/stigs/net_perimeter/enclave-dmzs/Pages/index.aspx

### Asset Based Text

**Document Title:** NIPRNet DoD DMZ Policy STIS  
**Document Benchmark ID:** NIPRNet_DoD_DMZ  
**URL:** https://iase.disa.mil/stigs/net_perimeter/enclave-dmzs/Pages/index.aspx

**Document Title:** Cloud Computing Security Requirements Guide  
**Document Benchmark ID:** Cloud_SRG  
**URL:** https://iase.disa.mil/cloud_security/Pages/index.aspx

**Document Title:** Cloud Computing Security Requirements Guide  
**Document Benchmark ID:** Cloud_SRG  
**URL:** https://iase.disa.mil/cloud_security/Pages/index.aspx

**Document Title:** BIND 9.x Security Technical Implementation Guide  
**Document Benchmark ID:** BIND_9-x_STIG  
**URL:** https://iase.disa.mil/stigs/net_perimeter/network-other/Pages/index.aspx
9 Example

9.1 Scenario

You are tasked with securing a system on a VMWare-based cloud environment. The VM is running Windows 10 and has several applications installed including JRE 8, Microsoft Office 2016, Dot Net Framework 4.0, and an HBSS Agent. To secure this system you need to know what policy documents to follow, and with that in mind you turn to the SRG/STIG Applicability Guide.

1. Add a new Collection and Name It accordingly.

2. Add a Cloud Service Asset (For this scenario we will be using Guide Mode).
3. Add a VM (Note, you will have to say no to a few prompts before being prompted to add a VM).
4. Add the Windows 10 OS.
5. Add the necessary applications (JRE 8, MS Office 2016, .Net Framework 4.0, HBSS Agent).
Note: You can check multiple items at once on the application page.

6. Now that you have finished building up your collection you can go on to preview the policy documents by navigating to View → Document List….
7. To save your collection navigate to File  Save Collection As….

8. Next navigate to File  Export Requirements Document  Export Requirements Document As HTML… and choose an appropriate name and location then save the document.

9. The exported document should look like this:

- **Document Title:** Cloud Computing Security Requirements Guide
  - **Document Benchmark ID:** Cloud_SRG
  - **URL:** https://iase.dia.mil/cloud_security/Pages/index.aspx

- **Document Title:** HBSS_McAfee_Agent_STIG
  - **Document Benchmark ID:** HBSS_McAfee_Agent
  - **URL:** https://iase.dia.mil/stigs/hbss/Pages/index.aspx

- **Document Title:** Java Runtime Environment (JRE) version 8 STIG for Windows
  - **Document Benchmark ID:** RE_8_and_Windows_STIG
  - **URL:** https://iase.dia.mil/stigs/JRE/Pages/a-z.aspx

- **Document Title:** Microsoft Dot Net Framework 4.0 STIG
  - **Document Benchmark ID:** MS_Dot_Net_Framework
  - **URL:** https://iase.dia.mil/stigs/app-security/app-services/Pages/index.aspx

- **Document Title:** Microsoft Office System 2016
  - **Document Benchmark ID:** Microsoft_Office_System_2016
  - **URL:** https://iase.dia.mil/stigs/app-security/office-auto/Pages/office2016.aspx

- **Document Title:** VMware vSphere Virtual Machine Version 6 Security Technical Implementation Guide
  - **Document Benchmark ID:** VMware_vSphere_Virtual_Machine_6.0_STIG
  - **URL:** https://iase.dia.mil/stigs/vmware/virtualization/Pages/index.aspx

- **Document Title:** Windows 10 Security Technical Implementation Guide
  - **Document Benchmark ID:** Windows_10_STIG
  - **URL:** https://iase.dia.mil/stigs/os/windows/Pages/index.aspx